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ABSTRACT

Simulation Modeling with Artificial Reality Technology
(SMART) is a simulation modeling tool that provides 
virtual reality interface for building graphical simulatio
models.  The simulation models, comprised of nodes 
arcs, are constructed in three dimensions.  As the 
builds a model, he may immerse himself in it using virtu
reality hardware and software tools and take advantag
the three dimensional environment provided by SMAR
Models built using SMART can be exported to AweSi
and simulated as SLAM models (Pristker et al, 1996).  T
virtual reality hardware includes an electronic glove a
head-mounted display.  The specific hardware is the 5
Glove (Fifth Dimension Technologies, 1996) and VIO 
Glasses (Virtual I-O, 1995), respectively.

By wearing the 5DT Glove, the user can naviga
through virtual space and manipulate a three dimensio
simulation model.  The VIO I-Glasses allows the user
experience immersion in the virtual modeling world.  T
head-mounted device constantly responds to the motion
the user’s head to reflect changes in his view of the virt
world.  With SMART, simulation practitioners are n
longer restricted to building simulation models on a f
two dimensional space.  Rather, they can now build th
dimensional simulation models with high non-plan
complexity through the virtual reality interface provided 
SMART.

1 INTRODUCTION

Virtual reality has been explored for several yea
One of its initial pioneers was Jaron Lanier who develop
many of its basic concepts (Porter, 1992).  Due to 
decreasing cost and increasing power of computers, vir
reality is being implemented by many industries such
aviation (Longhurst, 1995), medical (Hollands et al, 199
and manufacturing (Expert System, 1995) to address 
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areas like training, design, and testing.  The th
dimensional visualization capability of virtual reality is th
primary reason why this advanced technology is becom
the interface of the future for computing.  The softwa
system, SMART has been developed to explore the us
virtual reality in building simulation models.  SMART als
serves as a prototype for testing the feasibility of creatin
virtual reality simulation modeling software system on
relatively low-cost personal computer (PC).

The simulation models built by SMART can b
exported and then simulated by AweSim as SLAM mod
to analyze systems.  AweSim is a general purp
simulation tool developed by Pristker Corporati
(Pritsker, 1996).  AweSim and SLAM were chosen for t
research but the concepts of SMART may be implemen
to build any network based simulation model.  T
minimum system configuration for SMART is a Pentiu
200 MHz processor with 32 Mbytes of  RAM and 
Mbytes of video memory.

2 VIRTUAL REALITY HARDWARE

SMART offers a three dimensional interface using virt
reality hardware which  includes an electronic glove a
head-mounted display.  Manufactured by the Fi
Dimension Technologies, the electronic glove is known
the 5DT Glove.  The head-mounted display is called 
VIO I-Glasses and it is manufactured by Virtual I-O.

2.1 DT Glove

The 5DT Glove is used by SMART as the prima
manual input device.  The electronic glove is plugged i
a PC’s serial port.  The configuration parameters of 
5DT Glove such as the bending angle of each finger 
pitch and roll of the wrist are constantly sampled by 
PC’s serial connection and sent to SMART for process
The user controls SMART using a set of gestures to ca
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actions to be taken when building simulation models.  
example, the “grasp” gesture will cause a SLAM node
be selected for editing.  When a recognizable gestur
detected, SMART responds with the appropriate action
provides audio feedback confirming the action.  T
glove’s configuration and its relative position in the virtu
world are continuously animated by a robot-like ha
(Figure 1).  Every motion of the user’s fingers is reflec
by the animated hand in the virtual world.

Figure 1:  Animated Hand for 5DT Glove.

The basic actions controlled by the 5DT Glove are:

• Navigating (flying) through the virtual world;

• Grasping and repositioning simulation nodes;

• Adding text and simulation nodes to the virtual wo
model;

• Editing existing text and simulation nodes;

• Connecting simulation nodes with activities; and

• Transferring from one virtual world to anoth
instantaneously.

2.2  VIO I-Glasses

In addition to the 5DT Glove, SMART also uses the VIO
Glasses as another virtual reality hardware interf
especially for simulation model immersion enhancem
The device is plugged into a PC’s serial port.  The VIO
Glasses are designed to give the user the impression th
or she is physically present in the virtual modeling wo
This is accomplished by providing a virtual view using 
VIO I-Glasses which reacts directly to two primary he
motions: pitching (Figure 2) and yawing (Figure 3
Pitching is equivalent to nodding the head up and do
and yawing is swinging the head left and right.  
SMART, the ranges for pitching and yawing are ±60° and
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±360° respectively.  The user is  allowed to pitch and ya
simultaneously.

Figure 2:  VIO I-Glasses Pitching (Virtual I-O, 1995).

Figure 3:  VIO I-Glasses Yawing (Virtual I-O, 1995).

To use the I-Glasses to build simulation models,  t
user simply needs to put on the VIO I-Glasses and lo
around the way he usually does in real world.  The curr
pitching and yawing angles are continuously sampled a
the this data is used to compute the orientation of 
virtual view.  As the orientation of the user changes, t
virtual world is rendered accordingly.

3 MENUS

SMART  has five categories of menus that specify  
actions.  Most of these commands can also be execu
using specific gestures on the 5DT Glove.  The menus 
File, Edit, View, Glove, and Help.

3.1 File

The File menu allows the user to save and open the th
dimensional simulation models stored in SMART forma
Two important commands found in the File menu a
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Export Network and Export Control.  Using thes
commands, the user can convert and export the simula
models built using SMART into statements that can 
processed and simulated by the AweSim/SLAM simulato

3.2 Edit

The Edit menu allows the user to add new thr
dimensional Network and Control nodes into the virtu
modeling world.  The user can use the commands foun
the menu to edit the properties of each node such a
parameters and color.  In addition, the user can use
Text command in the menu to add three dimensional 
for visually documenting the three dimensional simulati
models.

3.3 View

Using the View menu, the user can show or hide the st
bar of the window.  Also, the user can instantaneou
switch between the two virtual worlds provided 
SMART.  One world is used to build the netwo
simulation models, using three dimensional versions
SLAM nodes.  The other world is used to build th
simulation control model, where general model parame
are specified.

3.4 Glove

The Glove menu consists of the single command, Mod
The user can use the command to bring up a dialog 
provides four options concerning the 5DT Glove:

• Loading an existing user setting;

• Defining and calibrating a new user setting;

• Viewing/Changing the current user setting; and

• Deleting an existing user setting.

Because the dimensions of every individual’s hand
different, it is necessary for the user to calibrate the sett
of the 5DT Glove such that every user receives the m
accurate responses from the electronic glove.  Users
save these setting and recall them later.
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3.5 Help

The Help menu lets the user read the general informat
regarding SMART.

4 EXAMPLE APPLICATIONS

To illustrate the use of SMART, a product distributio
center is modeled.  It has two levels: top and bottom.  Ite
arrive at the top level of the distribution center every 1
minutes.  Both the top and bottom level consist of a waiti
area and three work stations.  In either level, the wo
stations are laid out in a triangle with the waiting are
located in the middle.  The function of the waiting areas
to store the incoming items when the work stations a
busy. Basically, the items flow from the top level to th
bottom level before exiting the distribution center (Figure 

Figure 4:  System Schematic of Distribution Center Mode

Because of the nature of the distribution facility, the item
can either circulate around the top level or move on to 
lower level after they have been serviced by the wo
stations. A three dimensional simulation model was bu
using SMART in order to illustrate the physical thre
dimensional flow of the model.  The model is shown 
Figure 5, Figure 6, and Figure 7.

Items enter at the top of the model, through th
CREATE node (Figure 6).  They then progress to the fi
layer and may wait at the QUEUE node, or circulate 
various processing stations.  After processing in level 
they move to the lower level for similar processing (Figu
7).  Finally, they exit the system through the TERMINAT
node at the bottom of the model.

In

Out

Top Level

Bottom Level
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Figure 5:  Distribution Center Model - SMART View 1.

Figure 6:  Distribution Center Model - SMART View 2.

Figure 7:  Distribution Center Model - SMART View 3.

The standard two dimensional model, shown in Figure 8
provided for comparison purposes.  The non-planar nat
of this network model makes it more difficult to
comprehend in two dimensions.
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Figure 8:  Distribution Center Model - 2D View.

Using three dimensional capabilities, SMART visually
presents the physical flow of the simulation model.  The
work stations are modeled in a triangular form and joined
in the middle where the waiting area is located.
Furthermore, the top and bottom level of the distribution
center are clearly distinguished by the three dimensional
model in SMART.  It is difficult to show the actual
physical flow of the distribution center using the two
dimensional simulation model.

The user can apply the capabilities of SMART to build
these models and interact with them.  He can “fly” through
the three dimensional model as if it actually exits.  He can
select various symbol to edit and construct the model to
reflect the construction of the physical system or address
organization and presentation issues concerned with the
layout of the model.

5 CONCLUSIONS

Several objectives have been accomplished in  developing
SMART.  First of all, SMART allows the user to use a
virtual reality interface to build complex simulation
models.  But more importantly, the user can interact with
the models using advanced virtual reality hardware such as
the 5DT Glove and VIO I-Glasses.

Secondly, SMART assures the feasibility of using
virtual reality to build simulation models on a low-cost PC.
The software tools used to develop SMART have
significantly optimized the graphical rendering process
which could only be accomplished on a powerful,
expensive graphics workstation a few years ago.

6 FURTHER RESEARCH

Several ideas for further research have been developed
through the creation of SMART.  First, stereoscopic view
can be added as an option to the VIO I-Glasses in order to
make the three dimensional symbols more realistic.
Second, it is suggested that an addition left glove should be
included as part of the hardware interface to enhance
usability and provide more interaction options.  These
could include virtual keyboards and two handed gestures.
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Third, the input data entry procedure using 
keyboard in SMART should be replaced by other m
efficient methods such as voice recognition input..  E
though the user can still see the keyboard while wea
the VIO I-Glasses, he or she is required to turn the h
back to the keyboard’s location for typing input data.  W
voice input, the user can enter input data as he or
speaks.

Next, the capabilities of SMART should be extend
to provide three dimensional animation.  Tools for build
an animation driven by a simulation model in a virtu
reality modeling world should be included in addition 
tools for interacting with an executing simulation model.

Finally, the orientation and configuration of the da
glove should be graphically illustrated during t
calibration of each gesture.  The graphical illustratio
should include a picture of the appropriate gesture as 
as an animation of the  gesture that the user is makin
assure that it is accurate.
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